POJ 2739 Sum of Consecutive Prime Numbers

Sum of Consecutive Prime Numbers
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 19035   Accepted: 10435

Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
Your mission is to write a program that reports the number of representations for the given positive integer.

Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

Sample Input

2
3
17
41
20
666
12
53
0

Sample Output

1
1
2
3
0
0
1
2

Source

Japan 2005


题目大意:

一些正整数能表示为一个或多个连续素数的和。给出一个正整数,求有多少个这样的表示。


我的解法就是给出一组测试数据n,就求出这个数n范围内的素数集合,保存到数组中。在用一循环求连续素数的和,等于n,sum+1;

#include <iostream>
#include <math.h>
using namespace std;
int main()
{	
	int n;
	while(cin>>n&&n)
	{
		int sushu[10001]={0};
		int i,j,m,k=1;
		for(i=2;i<=n;i++)
		{
			m=int(sqrt((double)i)); 
			for(j=2;j<=m;j++)
			{
				if(i%j==0)
					break;
			}
			if(j>m)
			{
				sushu[k]=i;
				k++;
			}
		}
		int sum=0,sum1;
		for(i=1;i<k;i++)
		{
			sum1=0;
			for(j=i;j<k;j++)
			{
				sum1=sum1+sushu[j];
				if(sum1==n)
					sum=sum+1;
				else if(sum1>n)
					break;
			}
		}
		cout<<sum<<endl;
	}
	
	return 0;
}









你可能感兴趣的:(POJ 2739 Sum of Consecutive Prime Numbers)