胜利大逃亡(续)
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4057 Accepted Submission(s): 1342
Problem Description
Ignatius再次被魔王抓走了(搞不懂他咋这么讨魔王喜欢)……
这次魔王汲取了上次的教训,把Ignatius关在一个n*m的地牢里,并在地牢的某些地方安装了带锁的门,钥匙藏在地牢另外的某些地方。刚开始Ignatius被关在(sx,sy)的位置,离开地牢的门在(ex,ey)的位置。Ignatius每分钟只能从一个坐标走到相邻四个坐标中的其中一个。魔王每t分钟回地牢视察一次,若发现Ignatius不在原位置便把他拎回去。经过若干次的尝试,Ignatius已画出整个地牢的地图。现在请你帮他计算能否再次成功逃亡。只要在魔王下次视察之前走到出口就算离开地牢,如果魔王回来的时候刚好走到出口或还未到出口都算逃亡失败。
Input
每组测试数据的第一行有三个整数n,m,t(2<=n,m<=20,t>0)。接下来的n行m列为地牢的地图,其中包括:
. 代表路
* 代表墙
@ 代表Ignatius的起始位置
^ 代表地牢的出口
A-J 代表带锁的门,对应的钥匙分别为a-j
a-j 代表钥匙,对应的门分别为A-J
每组测试数据之间有一个空行。
Output
针对每组测试数据,如果可以成功逃亡,请输出需要多少分钟才能离开,如果不能则输出-1。
Sample Input
4 5 17
@A.B.
a*.*.
*..*^
c..b*
4 5 16
@A.B.
a*.*.
*..*^
c..b*
Sample Output
思路:
将钥匙压缩用二进制压缩就好了。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 22
using namespace std;
int n,m,t,ans;
int sx,sy,ex,ey;
char s[maxn];
char mp[maxn][maxn];
int dx[]= {-1,1,0,0};
int dy[]= {0,0,-1,1};
bool vis[maxn][maxn][1024];
struct Node
{
int x,y;
int state,step;
} cur,now,q[maxn*maxn*1024];
bool bfs()
{
int i,j,nx,ny,nst,tx,ty,tst,tmp;
int head=0,tail=-1;
memset(vis,0,sizeof(vis));
cur.x=sx;
cur.y=sy;
cur.state=0;
cur.step=0;
vis[sx][sy][0]=1;
q[++tail]=cur;
while(head<=tail)
{
now=q[head];
head++;
nx=now.x;
ny=now.y;
nst=now.state;
if(now.step>=t-1) break ;
for(i=0; i<4; i++)
{
tst=nst;
tx=nx+dx[i];
ty=ny+dy[i];
if(tx<1||tx>n||ty<1||ty>m||mp[tx][ty]=='*') continue ;
if(mp[tx][ty]>='a'&&mp[tx][ty]<='j')
{
tmp=mp[tx][ty]-'a';
tst=tst|(1<<tmp);
if(vis[tx][ty][tst]) continue ;
}
else
{
if(vis[tx][ty][tst]) continue ;
if(mp[tx][ty]>='A'&&mp[tx][ty]<='J')
{
tmp=mp[tx][ty]-'A';
if((tst&(1<<tmp))==0) continue ;
}
}
if(tx==ex&&ty==ey)
{
ans=now.step+1;
return true ;
}
cur.x=tx;
cur.y=ty;
cur.state=tst;
cur.step=now.step+1;
vis[tx][ty][tst]=1; // 标记呀 害我RE了两次
q[++tail]=cur;
}
}
return false ;
}
int main()
{
int i,j;
while(~scanf("%d%d%d",&n,&m,&t))
{
for(i=1; i<=n; i++)
{
scanf("%s",s);
for(j=1; j<=m; j++)
{
mp[i][j]=s[j-1];
if(mp[i][j]=='@') sx=i,sy=j;
if(mp[i][j]=='^') ex=i,ey=j;
}
}
if(bfs()) printf("%d\n",ans);
else printf("-1\n");
}
return 0;
}