poj 1258Agri-Net-最小生成树prim

                                                                                                                                                      Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30019   Accepted: 11927

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

/求最小生成树,只不过这题的话就是用矩阵表示,其实也一样,反而更简单~
省去了一些步骤!!!用矩阵当中的map[i][j]表示从i到j的路径
做的过程中WA了两次,原因是因为scanf()没有用EOF结束输入!!!下回注意啊
代码:

#include<cstdio>
#include<cmath>
#include<string>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cstring>
using namespace std;
#define INF 9999999
int map[101][101];
int dis[101];
int vis[101];
int n,m,k;
int x,y,w;
int Prim(){
	memset(vis,0,sizeof(vis));
	int sum=0; 
	for(int i=1;i<=n;i++)
		dis[i]=map[1][i];
	vis[1]=1;                
	for(int i=1;i<n;i++){
		int min=INF;
		for(int j=1;j<=n;j++)
			if(!vis[j]&&dis[j]<min){
				min=dis[j];
				k=j;
			}
			sum+=min;
			vis[k]=1;
			for(int j=1;j<=n;j++){
				if(!vis[j]&&map[k][j]<dis[j]){
					dis[j]=map[k][j];
				}
			}
	}
	return sum;
}
int main(){
	memset(map,0,sizeof(0));
	while(scanf("%d",&n)!=EOF){
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
			scanf("%d",&map[i][j]);
	printf("%d\n",Prim());
	}
	return 0;
}


 

你可能感兴趣的:(poj 1258Agri-Net-最小生成树prim)