UVA 437 The Tower of Babylon (dp + DAG最长序列)

 The Tower of Babylon 

Perhaps you have heard of the legend of the Tower of Babylon. Nowadays many details of this tale have been forgotten. So now, in line with the educational nature of this contest, we will tell you the whole story:

The babylonians had n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions  . A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. They wanted to construct the tallest tower possible by stacking blocks. The problem was that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the babylonians can build with a given set of blocks.

Input and Output

The input file will contain one or more test cases. The first line of each test case contains an integer n, representing the number of different blocks in the following data set. The maximum value for n is 30. Each of the next n lines contains three integers representing the values  ,  and  .

Input is terminated by a value of zero (0) for n.

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height"

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题意:给定n种立方体,每种都有无限个,每个立方体可以任意摆放,现在要叠这些立方体,要满足条件上面的一个底面必须包含在下面一个的顶面,要求最大能摆放多高。

思路:dp,DGA最长序列问题。每种立方体有3种摆放方式。在输入的时候保存下来即可

代码:

#include <stdio.h>
#include <string.h>
#include <limits.h>

int n, i, j, a ,b , c, d[105], ans;
struct Box {
	int x, y, z;
} box[105];

void dp(int now) {
	int i;
	for (i = 1; i <= 3 * n; i ++) {
		if (((box[now].x > box[i].x && box[now].y > box[i].y) || (box[now].x > box[i].y && box[now].y > box[i].x)) && d[now] + box[i].z > d[i]) {
			d[i] = d[now] + box[i].z;//记忆化搜索。
			dp(i);
		}
	}
	if (ans < d[now])
		ans = d[now];
}
int main() {
	int t = 1;
	while (~scanf("%d", &n) && n) {
		ans = 0;
		memset(d, 0, sizeof(d));
		box[0].x = box[0].y = box[0].z = INT_MAX;
		for (i = 1; i <= 3 * n; i += 3) {//3种摆放方式
			scanf("%d%d%d", &a, &b, &c);
			box[i].x = a; box[i].y = b; box[i].z = c;
			box[i + 1].x = b; box[i + 1].y = c; box[i + 1].z = a;
			box[i + 2].x = a; box[i + 2].y = c; box[i + 2].z = b;
		}
		dp(0);
		printf("Case %d: maximum height = %d\n", t ++, ans);
	}
	return 0;
}


你可能感兴趣的:(UVA 437 The Tower of Babylon (dp + DAG最长序列))