joj2218

 2218: Stamps

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
5s 8192K 299 151 Standard

Background 
Everybody hates Raymond. He's the largest stamp collector on planet earth and because of that he always makes fun of all the others at the stamp collector parties. Fortunately everybody loves Lucy, and she has a plan. She secretly asks her friends whether they could lend her some stamps, so that she can embarrass Raymond by showing an even larger collection than his. 

Problem 
Raymond is so sure about his superiority that he always tells how many stamps he'll show. And since Lucy knows how many she owns, she knows how many more she needs. She also knows how many friends would lend her some stamps and how many each would lend. But she'd like to borrow from as few friends as possible and if she needs too many then she'd rather not do it at all. Can you tell her the minimum number of friends she needs to borrow from?

Input Specification

The first line contains the number of scenarios. Each scenario describes one collectors party and its first line tells you how many stamps (from 1 to 1000000) Lucy needs to borrow and how many friends (from 1 to 1000) offer her some stamps. In a second line you’ll get the number of stamps (from 1 to 10000) each of her friends is offering.

Output Specification


The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line with the minimum number of friends Lucy needs to borrow stamps from. If it’s impossible even if she borrows everything from everybody, write impossible. Terminate the output for the scenario with a blank line.

Sample Input

3
100 6
13 17 42 9 23 57
99 6
13 17 42 9 23 57
1000 3
314 159 265

Sample Output

Scenario #1:
3

Scenario #2:
2

Scenario #3:
impossible

Problem Source: TUD Contest 2005, Darmstadt, Germany

这个题目比较简单不说了






#include<stdio.h>
#include<algorithm>
using namespace std;
int stamp[1002];
bool cmp(int i,int j)
{
    if(i>j)return true;
    return false;
}
int main()
{
    freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n)==1)
    {
        for(int u=1;u<=n;u++)
        {
            int sum;
            int person;
            scanf("%d%d",&sum,&person);
            for(int i=0;i<person;i++)
            scanf("%d",&stamp[i]);
            sort(stamp,stamp+person,cmp);
            int count=0;
            int i=0;
            while(sum>0&&i<person)
            {
                sum-=stamp[i];
                i++;
                count++;
            }
            printf("Scenario #%d:\n",u);
            if(sum<=0)
            printf("%d\n\n",count);
            else
            printf("impossible\n\n");
        }
    }
    return 0;
}

你可能感兴趣的:(joj2218)