UESTC 1271(动态规划入门)

C - C
Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format:%lld & %llu
Submit  Status  Practice  UESTC 1271

Description

Dreams of finding lost treasure almost came true recently. A new machine called 'The Revealer' has been invented and it has been used to detect gold which has been buried in the ground. The machine was used in a cave near the seashore where – it is said – pirates used to hide gold. The pirates would often bury gold in the cave and then fail to collect it. Armed with the new machine, a search party went into the cave hoping to find buried treasure. The leader of the party was examining the soil near the entrance to the cave when the machine showed that there was gold under the ground. Very excited, the party dug a hole two feel deep. They finally found a small gold coin which was almost worthless. The party then searched the whole cave thoroughly but did not find anything except an empty tin trunk. In spite of this, many people are confident that 'The Revealer' may reveal something of value fairly soon.

So,now you are in the point (1,1) and initially you have 0 gold.In the  n* m grid there are some traps and you will lose gold.If your gold is not enough you will be die.And there are some treasure and you will get gold.If you are in the point(x,y),you can only walk to point  (x+1,y),(x,y+1),(x+1,y+2)and (x+2,y+1).Of course you can not walk out of the grid.Tell me how many gold you can get most in the trip.

It`s guarantee that (1,1)is not a trap;

Input

first come  2 integers,  n,m( 1≤n≤1000, 1≤m≤1000)

Then follows  n lines with  m numbers  aij

(−100<=aij<=100)

the number in the grid means the gold you will get or lose.

Output

print how many gold you can get most.

Sample Input

3 3 
1 1 1 
1 -5 1 
1 1 1

3 3 
1 -100 -100 
-100 -100 -100 
-100 -100 -100

Sample Output

5

1


解体思路:简单的最优子结构问题,不需要走回头路,用dp做才不会超时。


代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF -0x3f3f3f3f
using namespace std;
int map[1010][1010];
int re[1010][1010];
int main(){
	int n,m,i,j;
	int a,b,ans;
	while(scanf("%d%d",&n,&m)!=EOF){
	  for(i=1;i<=n;i++){
		for(j=1;j<=m;j++){
			scanf("%d",&map[i][j]);
			a=INF;
		    if(i==1&&j==1){
		    	re[i][j]=map[i][j];
		    	ans=map[i][j];
		    	continue;
		    }
		    if(i>1) a=max(a,re[i-1][j]);
		    if(j>1) a=max(a,re[i][j-1]);
		    if(i>1&&j>2) a=max(a,re[i-1][j-2]);
		    if(i>2&&j>1) a=max(a,re[i-2][j-1]);
            re[i][j]=a+map[i][j];
            if(re[i][j]<0){
            	re[i][j]=INF;
            }
            if(re[i][j]>ans){
            	ans=re[i][j];
            }
		}
	}
	printf("%d\n",ans);
}
	return 0;
}


你可能感兴趣的:(UESTC 1271(动态规划入门))