【01背包】Bone Collector

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
【01背包】Bone Collector_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14


01背包:

#include<iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ; 
int n , m ;
int dp[60000], wei[60000] , val[60000];
int main()
{
	int  t ;
	cin>> t ; 
	while(t--)
	{
		memset(dp,0,sizeof(dp));
		memset(wei,0,sizeof(wei));
		memset(val,0,sizeof(val));
		cin>>n>>m;
		for(int i = 1 ; i<= n ; i++)
		{
			cin>>val[i];
		}
		for(int i = 1 ; i<= n ; i++)
		{
			cin>>wei[i];
		}
		for(int i = 1 ; i<= n ; i++)
		{
			for(int j = m ;j>=wei[i] ;j--)
			{
				dp[j] = max(dp[j] , dp[j-wei[i]]+val[i]); 
			}
		}
		cout<<dp[m]<<endl;
	}
	return 0 ;
}



你可能感兴趣的:(【01背包】Bone Collector)