Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.
Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.
Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.
Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.
Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.
The end of input is indicated by N = K = 0.
Output
For each case, output the sum of all the elements in M’ in a line.
Sample Input
4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0
Sample Output
14
56
题意:求矩阵C = A*B ,然后求C^(n*n) ,然后每个数字%6求和
思路: 设ans = (A*B) * (A*B).... = A*(B*A)*(B*A)...*B,然后B*A就能快速幂了
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
typedef long long ll;
using namespace std;
const int maxn = 1005;
const int mod = 6;
struct Matrix {
int arr[maxn][maxn];
int x, y;
Matrix() {
memset(arr, 0, sizeof(arr));
x = 0, y = 0;
}
void init() {
memset(arr, 0, sizeof(arr));
}
} A, B, C, D, E;
struct matrix {
int arr[10][10];
int x, y;
matrix() {
memset(arr, 0, sizeof(arr));
x = 0, y = 0;
}
void init() {
memset(arr, 0, sizeof(arr));
}
} a, b;
int n, k;
void Mul() {
for (int i = 0; i < B.x; i++)
for (int j = 0; j < A.y; j++)
for (int k = 0; k < B.y; k++)
a.arr[i][j] = (a.arr[i][j] + B.arr[i][k] * A.arr[k][j]) % mod;
}
matrix mul(matrix x, matrix y) {
matrix z;
for (int i = 0; i < 10; i++)
for (int j = 0; j < 10; j++)
for (int k = 0; k < 10; k++)
z.arr[i][j] = (z.arr[i][j] + x.arr[i][k] * y.arr[k][j]) % mod;
return z;
}
void Pow(int x) {
for (int i = 0; i < 10; i++)
for (int j = 0; j < 10; j++)
b.arr[i][i] = 1;
while (x) {
if (x & 1)
b = mul(b, a);
x >>= 1;
a = mul(a, a);
}
}
int main() {
while (scanf("%d%d", &n, &k) != EOF && n+k) {
A.init(), B.init(), C.init(), D.init(), E.init();
a.init(), b.init();
A.x = n, A.y = k;
for (int i = 0; i < n; i++)
for (int j = 0; j < k; j++)
scanf("%d", &A.arr[i][j]);
B.x = k, B.y = n;
for (int i = 0; i < k; i++)
for (int j = 0; j < n; j++)
scanf("%d", &B.arr[i][j]);
Mul();
/*
for (int i = 0; i < k; i++) {
for (int j = 0; j < k; j++)
printf("%d ", a.arr[i][j]);
printf("\n");
}
*/
Pow(n*n-1);
C.x = k, C.y = k;
for (int i = 0; i < 10; i++)
for (int j = 0; j < 10; j++)
C.arr[i][j] = b.arr[i][j];
for (int i = 0; i < A.x; i++)
for (int j = 0; j < C.y; j++)
for (int k = 0; k < A.y; k++)
D.arr[i][j] = (D.arr[i][j] + (A.arr[i][k] * C.arr[k][j]) % mod) % mod;
D.x = A.x, D.y = C.y;
for (int i = 0; i < D.x; i++)
for (int j = 0; j < B.y; j++)
for (int k = 0; k < D.y; k++)
E.arr[i][j] = (E.arr[i][j] + (D.arr[i][k] * B.arr[k][j]) % mod) % mod;
E.x = D.x, E.y = B.y;
int sum = 0;
for (int i = 0; i < E.x; i++)
for (int j = 0; j < E.y; j++)
sum += E.arr[i][j];
printf("%d\n", sum);
}
return 0;
}