并查集
How Many Tables
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9779 Accepted Submission(s): 4841
Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5
5 1
2 5
Sample Output
解题思路:设初始状态有n个桌子,然后每发现一对朋友,就减少一张桌子。。。
第一次写并查集.......大神勿喷
#include<stdio.h>
int num[1001];
int find(int x)//查找每一个元素所属的集合
{
while(num[x]!=x)
x=num[x];
return x;
}
int Union(int x,int y)//把两个元素放在同一个集合中
{
int a=find(x);
int b=find(y);
if(a==b)
return 0;
num[b]=a;
return 1;
}
int main()
{
int t,n,m,i,j,a,b,count;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
num[i]=i;
count=0;
for(i=1;i<=m;i++)
{
scanf("%d%d",&a,&b);
if(Union(a,b))
count++;//记录要减少多少桌子
}
printf("%d\n",n-count);
}
return 0;
}