POJ 3259 Wormholes

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 40421   Accepted: 14805

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold

点击打开题目链接POJ3259


题意:N个点,有 M 条双向道路(花费时间为T),W 条单向道路(花费时间为-T),判断是否存在负环

这里我们用 Bellman-Ford 算法先求最短路

如果没有负环,在迭代 N 次后将求出最短路,否则,最短路将不存在(沿着负环一直走,路就会更短)


代码:

#include <cstdio>
#include <iostream>
using namespace std;

const int MAXN = 500 + 10;
const int MAXM = 5000 + 1000;
const int INF = 1<<30;

int t, numOfPath;
int N, M, W;
int minLength[MAXN];

struct road
{
    int Begin, End, Length;
} Road[MAXM];

//保存一条从点 u 到点 v 长度为 w 的路径
void addPath(int u, int v, int w)
{
    Road[numOfPath].Begin = u;
    Road[numOfPath].End = v;
    Road[numOfPath++].Length = w;
}

//Bellman-Ford算法判断是否有负环
bool Bellman_Ford()
{
    for (int i = 1; i <= N; i++) minLength[i] = INF;
    minLength[1] = 0;

    for (int i = 0; i < N; i++)         //求最短路
    {
        for (int j = 0; j < numOfPath; j++)
        {
            int u = Road[j].Begin;
            int v = Road[j].End;
            int w = Road[j].Length;

            if (minLength[u] + w < minLength[v])    //松弛
                minLength[v] = minLength[u] + w;
        }
    }

    for (int i = 0; i < N; i++)
    {
        for (int j = 0; j < numOfPath; j++)
        {
            int u = Road[j].Begin;
            int v = Road[j].End;
            int w = Road[j].Length;

            if (minLength[u] + w < minLength[v])     //若还能进行松弛,说明不存在最短路而存在负环
                return true;
        }
    }
    return false;
}

int main()
{
    scanf("%d", &t);
    while (t--)
    {
        scanf("%d%d%d", &N, &M, &W);
        numOfPath = 0;
        int u, v, w;
        for (int i = 0; i < M; i++)     //双向道路
        {
            scanf("%d%d%d", &u, &v, &w);
            addPath(u, v, w);
            addPath(v, u, w);
        }
        for (int i = 0; i < W; i++)     //单向虫洞
        {
            scanf("%d%d%d", &u, &v, &w);
            addPath(u, v, -w);
        }
        if (Bellman_Ford() == true) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


你可能感兴趣的:(ACM,poj)