Problem Description
Number theory is interesting, while this problem is boring.
Here is the problem. Given an integer sequence a
1, a
2, …, a
n, let S(i) = {j|1<=j<i, and a
j is a multiple of a
i}. If S(i) is not empty, let f(i) be the maximum integer in S(i); otherwise, f(i) = i. Now we define bi as a
f(i). Similarly, let T(i) = {j|i<j<=n, and a
j is a multiple of a
i}. If T(i) is not empty, let g(i) be the minimum integer in T(i); otherwise, g(i) = i. Now we define c
i as a
g(i). The boring sum of this sequence is defined as b
1 * c
1 + b
2 * c
2 + … + b
n * c
n.
Given an integer sequence, your task is to calculate its boring sum.
Input
The input contains multiple test cases.
Each case consists of two lines. The first line contains an integer n (1<=n<=100000). The second line contains n integers a
1, a
2, …, a
n (1<= a
i<=100000).
The input is terminated by n = 0.
Output
Output the answer in a line.
Sample Input
Sample Output
136
题意:给你一个数组,让你生成两个新的数组,A要求每个数如果能在它的前面找个最近的一个是它倍数的数,那就变成那个数,否则是自己,C是往后找,输出交叉相乘的和
思路:扫描记录因子处理
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef __int64 ll;
const int MAXN = 100005;
int a[MAXN], b[MAXN], c[MAXN], vis[MAXN];
int n;
int main() {
while (scanf("%d", &n) == 1) {
if (n == 0)
break;
for (int i = 1; i <= n; i++)
scanf("%d", &a[i]);
memset(vis, 0, sizeof(vis));
for (int i = 1; i <= n; i++) {
if (vis[a[i]])
b[i] = a[vis[a[i]]];
else
b[i] = a[i];
for (int j = 1; j <= (int)sqrt((double)a[i]+0.5); j++) {
if (a[i] % j == 0) {
vis[j] = i;
vis[a[i] / j] = i;
}
}
}
memset(vis, 0, sizeof(vis));
for (int i = n; i >= 1; i--) {
if (vis[a[i]])
c[i] = a[vis[a[i]]];
else
c[i] = a[i];
for (int j = 1; j <= (int)sqrt((double)a[i]+0.5); j++) {
if (a[i] % j == 0) {
vis[j] = i;
vis[a[i] / j] = i;
}
}
}
ll sum = 0;
for (int i = 1; i <= n; i++) {
sum += (ll)b[i] * c[i];
}
printf("%I64d\n", sum);
}
return 0;
}