【杭电oj】1052 - Tian Ji -- The Horse Racing(田忌赛马,贪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25177    Accepted Submission(s): 7348


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

【杭电oj】1052 - Tian Ji -- The Horse Racing(田忌赛马,贪心)_第1张图片

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
   
   
   
   
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
   
   
   
   
200 0 0
 

Source
2004 Asia Regional Shanghai


这道题贪心的思路很好,主要策略分为以下几点:

①当田忌最慢的马比齐王最慢的马要快时,不用犹豫,比掉!

②当田忌最慢的马比齐王最慢的马慢时,把齐王最快的马拉下水(这个时候要注意有细节需要处理,下面说明)。

③当田忌最慢的马和齐王最慢的马速度相同时,这个时候两者打成平局不是最好的策略,这样打平不如用最慢的马把齐王的快马拉下水,再用田忌的快马去赢能赢的,这样收益同样为0,但齐王要损失快马,田忌后面的马才有可能获得胜利以获得更大的收益。


这个时候就拐回去说上面遗留的细节问题,如果田忌的快马本身就比齐王的快马快,那么用田忌的慢马拉齐王的快马则毫无意义,所以,应该先保证田忌的快马比齐王的快马慢。


综合上面的策略,按下面的顺序写代码就行了:

①先比较田忌的快马和齐王的快马,如果比齐王的快马快,则比掉。

②用田忌的慢马和齐王慢马比,如果比齐王快,则比掉;如果比齐王的慢,则把齐王的快马拉下水;如果速度相同,则也把齐王的快马拉下水。


代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
bool cmp(int a,int b)
{
	return a > b;
}
int main()
{
	int n;
	int t[1011];
	int q[1011];
	int t_max,t_min,q_max,q_min;
	int ans;
	while (~scanf ("%d",&n) && n)
	{
		for (int i = 1 ; i <= n ; i++)
			scanf ("%d",&t[i]);
		for (int i = 1 ; i <= n ; i++)
			scanf ("%d",&q[i]);
		sort (t+1,t+1+n,cmp);
		sort (q+1,q+1+n,cmp);
		t_max = 1;
		t_min = n;
		q_max = 1;
		q_min = n;
		ans = 0;
		while (t_max <= t_min && q_max <= q_min)
		{
			if (t[t_max] > q[q_max])		//如果田忌的快马比齐王的快,就比掉 
			{
				ans++;
				t_max++;
				q_max++;
			}
			else if (t[t_min] > q[q_min])		//田忌的慢马比齐王的慢马快,则比掉
			{
				ans++;
				t_min--;
				q_min--;
			}
			else
			{
				if (t[t_min] < q[q_max])		//如果田忌的慢马和齐王最快的一样就不用减钱了 
					ans--;
				t_min--;
				q_max++;
			}
		}
		printf ("%d\n",200*ans);
	}
	return 0;
}


你可能感兴趣的:(【杭电oj】1052 - Tian Ji -- The Horse Racing(田忌赛马,贪心))