HDU-ACM2055

An easy problem

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20018    Accepted Submission(s): 13313


Problem Description
we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
 

Input
On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.
 

Output
for each case, you should the result of y+f(x) on a line.
 

Sample Input
   
   
   
   
6 R 1 P 2 G 3 r 1 p 2 g 3
 

Sample Output
   
   
   
   
19 18 10 -17 -14 -4

import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner input=new Scanner(System.in);
        int t=input.nextInt();
        while (t-->0){
            char ch=(input.next()).charAt(0);
            int in=input.nextInt();
            int ch_i=0;
            if (ch>='A'&&ch<='Z'){
                ch_i=ch-64;
            }else if (ch>='a'&&ch<='z') {
                ch_i=-(ch-96);
            }
            int sum=ch_i+in;
            System.out.println(sum);
        }
    }
}


你可能感兴趣的:(java,算法,编程语言,ACM,杭电)