poj 2309 BST

BST
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9238   Accepted: 5650

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 
poj 2309 BST_第1张图片

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 2 31 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11

Source

POJ Monthly,Minkerui

题意:

就是找出他的最小的左子孙和最大的右子孙,这棵树和树状数组构成的树一样的,所以用树状数组来做;

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int lowbit(int x){
	return x&(-x);
}
int main()
{
	int i,t;
	int x,y,N;
	scanf("%d",&N);
	for(t=1;t<=N;t++){
		scanf("%d",&x);
		y=x;
		while(lowbit(x)!=1)	{
			x=x-lowbit(x)/2;
		}
		printf("%d %d\n",x,2*y-x);
	}
	return 0;
}



你可能感兴趣的:(poj 2309 BST)