南邮 OJ 1198 A_Mispelling4

A_Mispelling4

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 47            测试通过 : 30 

比赛描述

Misspelling is an art form that students seem to excel at. Write a program that removes the n-th character from an input string.




输入

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing M, a space, and a single word made up of uppercase letters only. M will be less than or equal to the length of the word. The length of the word is guaranteed to be less than or equal to 80.


输出

For each dataset, you should generate one line of output with the following values: The dataset

number as a decimal integer (start counting at one), a space, and the misspelled word. The

misspelled word is the input word with the indicated character deleted


样例输入

4
4 MISSPELL
1 PROGRAMMING
7 CONTEST
3 BALLOON

样例输出

1 MISPELL
2 ROGRAMMING
3 CONTES
4 BALOON

题目来源

Greater New York Region 2007




#include<stdio.h>
int main(){
	char c[81];
	int N,M,i;
	scanf("%d",&N);
	for(i=1;i<=N;i++){
		scanf("%d%s",&M,c);
		M--;
		while(c[M]){
			c[M]=c[M+1];
			M++;
		}
		printf("%d %s\n",i,c);
	}
}



你可能感兴趣的:(ACM,南邮OJ,A_Mispelling4)