poj 3050 Hopscotch DFS

Hopscotch
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 1605   Accepted: 1141

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

Source Code

Problem: 3050		
Memory: 756K		Time: 235MS
Language: C++		Result: Accepted
Source Code
#include <iostream>
#include <string>
#include <set>
using namespace std;
const int MAX = 5;
set<string> result;
char data[MAX][MAX];
int a[]={-1,0,1,0}, b[]={0,1,0,-1};

void DFS(int x, int y,int l,string s)
{
	if(l==6)
	{
		result.insert(s);
		return ;
	}
	for(int i=0; i <4; i++)
	{
		int tempx = x+a[i], tempy=y+b[i];
		if(tempx>=0 && tempx < 5 && tempy >=0 && tempy < 5)
		{
			string str = s;
			s += data[tempx][tempy];
			DFS(tempx, tempy,l+1, s);
			s = str;
		}
	}
	return ;
}

void solveCase()
{

	for(int i=0; i < 5; i++)
	{
		for(int j=0; j<5; j++)
		{
			DFS(i, j, 0, "");				
		}
	}
	cout << result.size() << endl;
}

int main()
{
	for(int i=0; i < 5; i++)
		for(int j=0; j < 5; j++)
			cin >> data[i][j];

	solveCase();

	return 0;
}


你可能感兴趣的:(C++,算法,ACM,poj,DFS)