南邮 OJ 1199 B_Conversions

B_Conversions

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 47            测试通过 : 22 

比赛描述

Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:




输入

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.


输出

For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.


样例输入

5
1 kg
2 l
7 lb
3.5 g
0 l

样例输出

1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g

题目来源

Greater New York Region 2007


#include<iostream>
#include<iomanip>
#include<string>
using namespace std;

int main(){
	int N,i;
	double d;
	string s;
	cin>>N;
	cout<<fixed<<setprecision(4);
	for(i=1;i<=N;i++){
		cin>>d>>s;
		cout<<i<<' ';
		if("kg"==s){
			cout<<d*2.2046<<" lb"<<endl;
		}else if("lb"==s){
			cout<<d*0.4536<<" kg"<<endl;
		}else if("l"==s){
			cout<<d*0.2642<<" g"<<endl;
		}else if("g"==s){
			cout<<d*3.7854<<" l"<<endl;
		}
	}
}






你可能感兴趣的:(ACM,南邮OJ,B_Conversions)