POJ 3670 Eating Together LIS最长递增子序列+二分查找 nlogn算法

http://poj.org/problem?id=3670

 

Eating Together
Time Limit: 1000MS   Memory Limit: 65536K



Description

The cows are so very silly about their dinner partners. They have organized themselves into three groups (conveniently numbered 1, 2, and 3) that insist upon dining together. The trouble starts when they line up at the barn to enter the feeding area.

Each cow i carries with her a small card upon which is engraved Di (1 ≤ Di ≤ 3) indicating her dining group membership. The entire set of N (1 ≤ N ≤ 30,000) cows has lined up for dinner but it's easy for anyone to see that they are not grouped by their dinner-partner cards.

FJ's job is not so difficult. He just walks down the line of cows changing their dinner partner assignment by marking out the old number and writing in a new one. By doing so, he creates groups of cows like 111222333 or 333222111 where the cows' dining groups are sorted in either ascending or descending order by their dinner cards.

FJ is just as lazy as the next fellow. He's curious: what is the absolute mminimum number of cards he must change to create a proper grouping of dining partners? He must only change card numbers and must not rearrange the cows standing in line.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i describes the i-th cow's current dining group with a single integer: Di

Output

* Line 1: A single integer representing the minimum number of changes that must be made so that the final sequence of cows is sorted in either ascending or descending order

Sample Input

5
1
3
2
1
1

Sample Output

1
/* Author : yan
 * Question : POJ 3670 Eating Together
 * Date && Time : Wednesday, December 22 2010 11:10 PM
*/
#include<stdio.h>
#define MAX 30000
int n;

int value[MAX];///记录原始数组
int opt[MAX+1];///记录长度为k的最长递增序列的结尾元素,下标从1开始
//int len[MAX];///记录以value[k]结尾的最长递增子序列的长度

int LIS(const int value[],const int n)
{
	int i,j;
	int size=1;
	opt[1]=value[0];
	//len[0]=1;
	for(i=1;i<n;i++)
	{
		if(value[i]<opt[1]) j=1;//<=换为<  后者为最长不减子序列
		else if(value[i]>=opt[size]) j=++size;// > 换为: >=  后者为最长不减子序列
		else j=binary_search(opt,size,value[i]);
		opt[j]=value[i];
		//len[i]=j;
	}
	return size;
}
int binary_search(const int opt[],const int size,const int value)
{
	int left=1;
	int right=size;
	int mid;
	while(left<=right)
	{
		mid=(left+right)>>1;
		if(value>=opt[mid] && value<opt[mid+1]) return mid+1;// >&&<= 换为: >= && <  后者为最长不减子序列
		else if(value<opt[mid+1]) right=mid-1;
		else left=mid+1;
	}
}
void reverse(int *value,int n)
{
	int i;
	int cache;
	int cnt=n>>1;
	for(i=0;i<cnt;i++)
	{
		cache=value[n-i-1];
		value[n-i-1]=value[i];
		value[i]=cache;
	}
}
int main()
{
	//freopen("input","r",stdin);

	int i,j;
	int ans;
	int max;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&value[i]);
	}
	ans=LIS(value,n);
	reverse(value,n);

	max=LIS(value,n);
	if(ans<max) ans=max;
	printf("%d",n-ans);
	return 0;
}
 

 

你可能感兴趣的:(POJ 3670 Eating Together LIS最长递增子序列+二分查找 nlogn算法)