POJ 2299 Ultra-QuickSort

Ultra-QuickSort

Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 24310 Accepted: 8696


Description
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input
5
9
1
0
5
4
3
1
2
3
0

Sample Output
6
0

Source
Waterloo local 2005.02.05

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define MAXN 500010
int n, a[MAXN], c[MAXN];

long long MergeSort(int left, int right){
	int i, j, k, mid;
	long long ans;
	if (left >= right) return 0;
	mid = (left + right) / 2;
	ans = MergeSort(left, mid) + MergeSort(mid + 1, right);
	for (i = left, j = mid + 1, k = left; i <= mid && j <= right; k++){
		if (a[i] < a[j]) c[k] = a[i++];
		else{
			c[k] = a[j++];
			ans += mid - i + 1;
		}
	}
	for (; i <= mid; i++, k++) c[k] = a[i];
	for (; j <= right; j++, k++) c[k] = a[j];
	for (i = left; i <= right; i++) a[i] = c[i];
/*	printf("m: (%d, %d) = %d\n", left, right, ans);
	for (i = left; i <= right; i++){
		printf("%d ", a[i]);
	}
	printf("\n");	
*/	return ans;
}

int main(){
	int i;
	while(scanf("%d", &n), n != 0){
		for (i = 0; i < n; i++) scanf("%d", &a[i]);
		printf("%lld\n", MergeSort(0, n - 1));
	}
	return 0;
}
/*
求逆序数,可以归并排序,离散化+树状数组
这里是归并排序
375MS 在g++里排整100...
WA了一次,结果要long long...最坏情况逆序排列,需交换n*(n+1)/2
*/

你可能感兴趣的:(POJ 2299 Ultra-QuickSort)