The Shortest Path
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2552 Accepted Submission(s): 807
Problem Description
There are N cities in the country. Each city is represent by a matrix size of M*M. If city A, B and C satisfy that A*B = C, we say that there is a road from A to C with distance 1 (but that does not means there is a road from C to A).
Now the king of the country wants to ask me some problems, in the format:
Is there is a road from city X to Y?
I have to answer the questions quickly, can you help me?
Input
Each test case contains a single integer N, M, indicating the number of cities in the country and the size of each city. The next following N blocks each block stands for a matrix size of M*M. Then a integer K means the number of questions the king will ask, the following K lines each contains two integers X, Y(1-based).The input is terminated by a set starting with N = M = 0. All integers are in the range [0, 80].
Output
For each test case, you should output one line for each question the king asked, if there is a road from city X to Y? Output the shortest distance from X to Y. If not, output "Sorry".
Sample Input
3 2
1 1
2 2
1 1
1 1
2 2
4 4
1
1 3
3 2
1 1
2 2
1 1
1 1
2 2
4 3
1
1 3
0 0
Sample Output
Source
HDU 2009-4 Programming Contest
Recommend
暴力模拟矩阵运算然后floyd
/*************************************************************************
> File Name: hdu2807.cpp
> Author: ALex
> Mail: [email protected]
> Created Time: 2015年01月03日 星期六 12时13分36秒
************************************************************************/
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 85;
const int inf = 0x3f3f3f3f;
int dp[N][N];
int n, m;
struct martix
{
int mat[N][N];
void clear()
{
memset (mat, 0, sizeof(mat));
}
}city[N][N], node[N];
void floyd()
{
for (int k = 1; k <= n; ++k)
{
for (int i = 1; i <= n; ++i)
{
for (int j = 1; j <= n; ++j)
{
dp[i][j] = min(dp[i][j], dp[i][k] + dp[k][j]);
}
}
}
}
void martix_mutiply(int a, int b)
{
city[a][b].clear();
for (int i = 1; i <= m; ++i)
{
for (int j = 1; j <= m; ++j)
{
for (int k = 1; k <= m; ++k)
{
city[a][b].mat[i][j] += node[a].mat[i][k] * node[b].mat[k][j];
}
}
}
}
bool is_same(int a, int b, int c)
{
for (int i = 1; i <= m; ++i)
{
for (int j = 1; j <= m; ++j)
{
if (city[a][b].mat[i][j] != node[c].mat[i][j])
{
return 0;
}
}
}
return 1;
}
int main()
{
while (~scanf("%d%d", &n, &m))
{
if (!n && !m)
{
break;
}
for (int i = 1; i <= n; ++i)
{
for (int j = 1; j <= m; ++j)
{
for (int k = 1; k <= m; ++k)
{
scanf("%d", &node[i].mat[j][k]);
}
}
}
memset (dp, inf, sizeof(dp));
for (int i = 1; i <= n; ++i)
{
dp[i][i] = 0;
}
for (int i = 1; i <= n; ++i)
{
for (int j = 1; j <= n; ++j)
{
if (i != j)
{
martix_mutiply(i, j);
}
}
}
for (int i = 1; i <= n; ++i)
{
for (int j = 1; j <= n; ++j)
{
if (i == j)
{
continue;
}
for (int k = 1; k <= n; ++k)
{
if (i == k || j == k)
{
continue;
}
if (is_same(i, j, k))
{
dp[i][k] = 1;
}
}
}
}
floyd();
int q;
scanf("%d", &q);
while (q--)
{
int x, y;
scanf("%d%d", &x, &y);
if (dp[x][y] == inf)
{
printf("Sorry\n");
}
else
{
printf("%d\n", dp[x][y]);
}
}
}
return 0;
}