Flip Game(状态压缩+BFS)

Link:http://poj.org/problem?id=1753


Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32393   Accepted: 14147

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Flip Game(状态压缩+BFS)_第1张图片Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

Northeastern Europe 2000

[Submit]   [Go Back]   [Status]   [Discuss]


解题思路参考自:http://blog.sina.com.cn/s/blog_768e348b0100x9ww.html
==================================
搜索题,用bfs搜索所有状态,为了避免重复,要开数组记录某个状态是否被访问过。
记录棋盘的状态的方式就是状态压缩,有十六个棋子,可以用数的二进制的16位来表示,1为黑面,0为白面
则0和65536为要求的最终状态。
而翻转棋盘的具体位置可以通过位运算的异或,与0异或不变,与1异或变反,要反转哪一位则先将1左移一定位数然后与之异或。
还个有问题是count的记录,即反转的次数,因为一个状态是继承于上一个状态的,所以count可以为上一个状态的count +1
==================================


AC code:


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct node{
	int cnt;
	int vis;
}sta[1<<16+1];
int head,tail,queue[(1<<16)*2],st;
char m[6][6];
const int AW=0x0;
const int AB=0xffff;
int BFS()
{
	head=tail=0;
	queue[tail++]=st;
	sta[st].cnt=0;
	sta[st].vis=1;
	while(head!=tail)
	{
		int tmp=queue[head++];
		if(tmp==AW||tmp==AB)
		{
			return sta[tmp].cnt;
		}
		for(int i=0;i<4;i++)
		{
			for(int j=0;j<4;j++)
			{
				int t=tmp;
				int pos=i*4+j;
				t^=1<<(15-pos);
				if(i>0)
				{
					t^=1<<(15-pos+4);
				}
				if(i<3)
				{
					t^=1<<(15-pos-4);
				}
				if(j>0)
				{
					t^=1<<(15-pos+1);
				}
				if(j<3)
				{
					t^=1<<(15-pos-1);
				}
				if(!sta[t].vis)
				{
					sta[t].cnt=sta[tmp].cnt+1;
					sta[t].vis=1;
					queue[tail++]=t;
				}
			}
		}
	}
	return -1;
}
int main()
{
	st=0;
	int n=-1,ans;
	for(int i=0;i<4;i++)
	{
		scanf("%s",&m[i]);
		for(int j=0;j<4;j++)
		{
			st*=2;
			if(m[i][j]=='b')
			{
				st+=1;
			}
		}
	}
	for(int i=0;i<=(1<<16);i++)
	{
		sta[i].cnt=0;
		sta[i].vis=0;
	}
	ans=BFS();
	if(ans==-1)
	{
		printf("Impossible\n");
	}
	else
	{
		printf("%d\n",ans);
	}
	return 0;
}
 


你可能感兴趣的:(位运算,算法,二进制,ACM,bfs)