POJ 3030 && HDU 2317 Nasty Hacks(水~)

Description
给出打广告后的收益,不打广告的收益以及广告费,问你是否需要打广告
Input
第一行为用例组数,每组用例占一行,包括三个整数r,e,c分别表示不大广告的收益,打广告的收益以及广告费
Output
对于每组用例,如果打广告收益大则输出advertise,如果不打广告收益大则输出do not advertise,如果打不打广告收益相同则输出does not matter
Sample Input
3
0 100 70
100 130 30
-100 -70 40
Sample Output
advertise
does not matter
do not advertise
Solution
纯净水
Code

#include<stdio.h>
int main()
{
    int n,r,e,c;
    scanf("%d",&n);
    while(n)
    {
        scanf("%d%d%d",&r,&e,&c);
        if(r+c>e)
            printf("do not advertise\n");
        else if(r+c==e)
            printf("does not matter\n");
            else 
                printf("advertise\n");
        n--;
    }
    return 0;
} 

你可能感兴趣的:(POJ 3030 && HDU 2317 Nasty Hacks(水~))