POJ 3692 Kindergarten 二分图最大独立集

POJ 3692Kindergarten 二分图最大独立集

Description

In a kindergarten, there are a lot of kids. All girls of the kids knoweach other and all boys also know each other. In addition to that, some girlsand boys know each other. Now the teachers want to pick some kids to play agame, which need that all players know each other. You are to help to findmaximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with aline containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ MG× B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y(1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y knoweach other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number(beginning with 1) followed by a integer which is the maximum number of kids theteacher can pick.

Sample Input

2 3 3

1 1

1 2

2 3

2 3 5

1 1

1 2

2 1

2 2

2 3

0 0 0

Sample Output

Case 1: 3

Case 2: 4

Source

2008 Asia Hefei Regional Contest Online by USTC


     

本题是要求图中的最大完全子图(最大团)中顶点的个数。由于原图的补图是一个二分图,其最大完全数等价于其补图的最大独立集中元素的个数,于是可以根据二分图的性质求出这个最大独立集。而普通图的最大团则是一个NP问题。

定理:二分图最大独立集=顶点数-二分图最大匹配

最大完全数:图中最大完全子图的顶点个数。

独立集:图中任意两个顶点都不相连的顶点集合。

·  /////////////////////////////////////////////////////////////////////

·  //独立集:任意两点都不相连的顶点的集合  

·  //独立数:独立集中顶点的个数  

·  //完全子图:任意两点都相连的顶点的集合  

·  //最大完全数:最大完全子图中顶点的个数  

·  //最大完全数=原图的补图的最大独立数  

·  //最大独立数=顶点数-最大匹配数  

·  //本题是要求图中的最大完全子图(最大团)中顶点的个数。  

·  //由于原图的补图是一个二分图,其最大完全数等价于其补图的最大独立集中元素的个数,  

·  //于是可以根据二分图的性质求出这个最大独立集。而普通图的最大团则是一个NP问题。  

·  //定理:二分图最大独立集=顶点数-二分图最大匹配  

·  //最大完全数:图中最大完全子图的顶点个数。  

·  //独立集:图中任意两个顶点都不相连的顶点集合。  

·  /////////////////////////////////////////////////////////////////////

///////*********做题要细心,一道水题,wa了好几次。******/////////

代码:

#include <iostream>

#include <cstring>

#include <cstdio>

using namespace std;

bool map[205][205];

int link[205];

bool vis[205];

int n,m,t;

bool dsf(int x)

{

       intj;

       for(j=1;j<=m;j++)

       {

         if(map[x][j]&&!vis[j])

         {

                vis[j]=true;

                if(!link[j]||dsf(link[j]))

                {

                       link[j]=x;

               

                    return true;//******//

                }

         }

       }

       returnfalse;

}

int main()

{

       intcnt=1,g,b;

       while(cin>>n>>m>>t&&n||m||t)

       {

       int i,j;

              //memset(map,true,sizeof(map));

              for(i=1;i<=n;i++)

                     for(j=1;j<=m;j++)

                            map[i][j]=true;

              memset(link,0,sizeof(link));

              while(t--)

              {

                     cin>>g>>b;

                     map[g][b]=false;

             

              }

             

              intans=0;

              intk;

           for(k=1;k<=n;k++)

              {

                     memset(vis,false,sizeof(vis));

                     if(dsf(k))

                            ans++;

              }

      

       printf("Case%d: %d\n",cnt++,n+m-ans);

       }

       return0;

}

 

 

你可能感兴趣的:(POJ 3692 Kindergarten 二分图最大独立集)