hdu 2602 Bone Collector(01背包)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24175    Accepted Submission(s): 9809


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
hdu 2602 Bone Collector(01背包)_第1张图片
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
   
   
   
   
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
   
   
   
   
14
 


最基础的01背包。给n个物品的价值和花费以及背包的容量,每个物品只有一件。问背包所放物品的最大价值。
f[ v ] = max ( f[ v ], f[ v - c[i] ] + w[i] )。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int f[1010],c[1010],w[1010];

int main()
{
	int test,n,m;
	scanf("%d",&test);
	while(test--)
	{
		scanf("%d %d",&n,&m);
		for(int i = 1; i <= n; i++)
			scanf("%d",&w[i]);
		for(int i = 1; i <= n; i++)
			scanf("%d",&c[i]);
		memset(f,0,sizeof(f));
		for(int i = 1; i <= n; i++)
		{
			for(int j = m; j >= c[i]; j--)//体积逆序
			{
				f[j] = max(f[j], f[j-c[i]]+w[i]);
			}
		}

		printf("%d\n",f[m]);
	}
	return 0;
}

 二维 dp[i][j] = max( dp[i-1][j] , dp[i-1][ j-c[i] ] + w[i ] ) (  0 <=j <= v)
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int dp[1010][1010];

int main()
{
	int test;
	int w[1010],c[1010],n,v;
	scanf("%d",&test);
	while(test--)
	{
		scanf("%d %d",&n,&v);
		for(int i = 1; i <= n; i++)
			scanf("%d",&w[i]);
		for(int i = 1; i <= n; i++)
			scanf("%d",&c[i]);

		memset(dp,0,sizeof(dp));

		for(int i = 1; i <= n; i++)
		{
			for(int j = 0; j <= v; j++)
			{
				if(j >= c[i])
					dp[i][j] = max(dp[i-1][j], dp[i-1][j-c[i]] + w[i]);
				else dp[i][j] = dp[i-1][j];
			}
		}
		printf("%d\n",dp[n][v]);

	}
	return 0;
}


你可能感兴趣的:(dp)