POJ 3273-Monthly Expense(二分+贪心)

B - Monthly Expense
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 3273

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M
Lines 2..  N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题意:

将N个账款分割成M个财务期,使得每个分期账款和的最大值最小。
思路:这题其实就是二分[最小金钱消耗,最大金钱消耗],一开始因为思路混乱了,所以认为二分不能精确到每一个数,所以方向搞错了。最后写了一个Wa的程序,最后看了题解才发现原来是可以精确到每一位的,所以改了二分的上下界就过了。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<vector>
#include<map>
#include<set>

using namespace std;
typedef long long ll;
#define T 100000+50
#define inf 0x3f3f3f3f

int N,M;
int a[T];

bool slove(int x)
{
	int cur=1,sum=0;
	for(int i=0;i<M;++i){
		sum += a[cur++];
		while(sum+a[cur]<=x)sum+=a[cur++];
		sum = 0;
		if(cur>=N)return true;
	}
	return false;
}

int main()
{
#ifdef zsc
	freopen("input.txt","r",stdin);
#endif

	int i,j,k;
	while(~scanf("%d%d",&N,&M))
	{
		int L=0,R=0,mid;
		for(i=1;i<=N;++i){
			scanf("%d",&a[i]);
			R += a[i];
			L = max(a[i],L);
		}
		int ans;
		while(L<=R)
		{
			mid = (L+R)/2;
			if(slove(mid)){
				ans = mid;
				R = mid-1;
			}
			else {
				L = mid+1;
			}
		}
		printf("%d\n",ans);
	}

	return 0;
}


你可能感兴趣的:(二分查找,贪心)