poj2406(KMP)

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 27614   Accepted: 11566

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source

Waterloo local 2002.07.01
 
本题要求给定字符串的最小重复子串的重复次数。即求给定的字符串的最小重复单元即可。
可用KMP算法求得next[len],若len%(len-next[len])==0,则最小重复单元的长度为next[len],n=len/(len-next[len]);否则给定的字符串不能由某个字串重复得到。
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN=1000000+100;
int next[MAXN];
char str[MAXN];


void getNext(char *p)
{
    int j,k;
    j=0;
    k=-1;
    int len=strlen(p);
    next[0]=-1;
    while(j<len)
    {
        if(k==-1||p[j]==p[k])
        {
            j++;
            k++;
            next[j]=k;
        }
        else k=next[k];
    }
}

void solve(int len)
{
	if(len%(len-next[len])!=0)
		printf("1\n");
	else 
		printf("%d\n",len/(len-next[len]));
}

int main()
{
//	freopen("in.txt","r",stdin);
	while(~scanf("%s",str))
	{
		if(strcmp(str,".")==0)
			break;
		getNext(str);
		solve(strlen(str));
	}
	return 0;
}

你可能感兴趣的:(数据结构,字符串,KMP)