POJ 3051 Satellite Photographs 简单DFS

http://poj.org/problem?id=3051

 

Satellite Photographs
Time Limit: 1000MS   Memory Limit: 65536K



Description

Farmer John purchased satellite photos of W x H pixels of his farm (1 <= W <= 80, 1 <= H <= 1000) and wishes to determine the largest 'contiguous' (connected) pasture. Pastures are contiguous when any pair of pixels in a pasture can be connected by traversing adjacent vertical or horizontal pixels that are part of the pasture. (It is easy to create pastures with very strange shapes, even circles that surround other circles.) 

Each photo has been digitally enhanced to show pasture area as an asterisk ('*') and non-pasture area as a period ('.'). Here is a 10 x 5 sample satellite photo: 

..*.....** 
.**..***** 
.*...*.... 
..****.*** 
..****.*** 

This photo shows three contiguous pastures of 4, 16, and 6 pixels. Help FJ find the largest contiguous pasture in each of his satellite photos.

Input

* Line 1: Two space-separated integers: W and H 

* Lines 2..H+1: Each line contains W "*" or "." characters representing one raster line of a satellite photograph.

Output

* Line 1: The size of the largest contiguous field in the satellite photo.

Sample Input

10 5
..*.....**
.**..*****
.*...*....
..****.***
..****.***

Sample Output

16
/* Author : yan
 * Question : POJ 3051 Satellite Photographs
 * Data && Time : Thursday, January 06 2011 01:40 PM
*/
#include<stdio.h>
#define bool _Bool
#define true 1
#define false 0
#define HIGHT 1000
#define WIDTH 80

char photo[HIGHT][WIDTH];
bool visited[HIGHT][WIDTH];

int w,h;
int cnt;

void DFS(int a,int b)
{
	if(a<0 || a>=h) return;
	if(b<0 || b>=w) return;
	if(visited[a][b]) return;
	if(photo[a][b]=='*')
	{
		cnt++;
		visited[a][b]=true;
		DFS(a-1,b);
		DFS(a,b-1);
		DFS(a+1,b);
		DFS(a,b+1);
	}
}
int main()
{
	//freopen("input","r",stdin);
	int i,j;
	int ans=-1;
	scanf("%d %d",&w,&h);
	for(i=0;i<h;i++)
		for(j=0;j<w;j++) scanf(" %c",&photo[i][j]);//这里要有空格,因为换行符也是字符
	for(i=0;i<h;i++)
	{
		for(j=0;j<w;j++)
		{
			if(visited[i][j]==false)
			{
				cnt=0;
				DFS(i,j);
				if(ans<cnt) ans=cnt;
			}
		}
	}
	printf("%d",ans);
	return 0;
}
 

 

你可能感兴趣的:(c,input,each,output,pair,Shapes)