南邮 OJ 1434 Fence

Fence

时间限制(普通/Java) :  1000 MS/ 3000 MS          运行内存限制 : 65536 KByte
总提交 : 68            测试通过 : 26 

比赛描述

In this problem, ‘lattice points’ in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a ‘hot’ wire from the origin (0,0) to a lattice point [n, m] (0<=;n<32000, 0<m<32000), then to a lattice point on the positive x axis [p,0] (p>0), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?




输入

First line contains an integer n: the number of test case.

Then n lines follow, each line contains three space-separated integers that denote n, m, and p.


输出

A single line with a single integer for each test case that represents the number of cows the specified fence can hold.


样例输入

2
7 5 10
1 1 2

样例输出

20
0

题目来源

NUPT ACM 2010 Personal Ranking Contest



// AC 15MS
#include<stdio.h>
int main(){
	int t,n,m,p,b,e,sum;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d%d",&n,&m,&p);
		sum = 0;
		for(int k=1; k<m; k++){
			b = (int)((float)(k*n)/m)-1;
			e = (int)((float)k*(n-p)/m)+p+1;
			while(!(b*m>k*n)){
				b++;
			}
			while(!((e-p)*m<k*(n-p))){
				e--;
			}
			sum += e-b+1;
		}
		printf("%d\n",sum);
	}
}






你可能感兴趣的:(ACM,fence,南邮OJ)