poj 1125 Stockbroker Grapevine 【多源点最短路】

Stockbroker Grapevine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 28840   Accepted: 15992

Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

Input

Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people.

Output

For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes.
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10
题目大概意思:要求用最短的时间使流言传播给所有人,人与人之间可以同时传递。 就是说,第三个人传播给第一个人花费2,传播给第二个人花费2,总花费为2.
思路:求出最短路后,枚举所有点,每次求出该点为源点的前提下所花费的时间(因为流言可以同时传递,所以传播过程中花费的最大时间就是当前点为源点的情况下的花费)
然后每次更新求出答案即可。
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 100+10
#define INF 0x3f3f3f
using namespace std;
int map[MAX][MAX];
int n;
void init()
{
    for(int i = 1; i <= n; i++)
    {
        for(int j = 1; j <= n; j++)
        {
            if(i == j)
            map[i][j] = 0;
            else
            map[i][j] = INF;
        }
    }
}
void getmap()
{
    int x, y, c, num;
    for(x = 1;x <= n; x++)
    {
        scanf("%d", &num);
        while(num--)
        {
            scanf("%d%d", &y, &c);
            if(map[x][y] > c)
            map[x][y] = c;
        }
    }
}
void floyd()
{
    int i, j, k;
    for(k = 1; k <= n; k++)
    {
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
            {
                if(map[i][j] > map[i][k] + map[k][j])
                map[i][j] = map[i][k] + map[k][j];
            }
        }
    }
}
void slove()
{
    int i, j; 
    int start;//起点 
    int ans = INF;//所需最少时间 
    int time;//记录每个人 传播给其他人的过程中花费的最大时间 
    for(i = 1;i <= n; i++)
    {
        time = 0;
        for(j = 1; j <= n; ++j)
        {
            if(i != j && map[i][j] > time)
            time = map[i][j];
        }
        if(time == INF)//i为源点不能传递给所有人 
        continue;
        if(ans > time)
        {
            ans = time;
            start = i;
        }
    }
    if(ans == INF)
    printf("disjoint\n");
    else
    printf("%d %d\n", start, ans);
}
int main()
{
    int i, j;
    while(scanf("%d", &n), n)
    {
        init();
        getmap();
        floyd();
        slove();
    }
    return 0;
} 

你可能感兴趣的:(poj 1125 Stockbroker Grapevine 【多源点最短路】)