POJ Stars

终于开始了我的POJ之旅,这是一题树状数组的基本题


Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
POJ Stars_第1张图片
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999


统计当前点左下方的点的个数,可以用树状数组的sum()求得,层数=左下方的星星数,然后更新,因为对于下一个点,他的左下方 的点的个数可能会又多一个

#include<stdio.h>
#include<string.h>

int tree[32005];
int level[32005];

int lowbit(int x)
{
return x&(-x);
}

void add(int x)
{
for(int i=x;i<=32005;i+=lowbit(i))
tree[i]++;//管理x的所有i,他们的左下角的点又多了个
}

int sum(int x)
{
int cnt=0;
for(int i=x;i;i-=lowbit(i))
cnt+=tree[i];
return cnt;
}

int main()
{
int n;
while(~scanf("%d",&n))
{
int x,y;
memset(tree,0,sizeof(tree));
memset(level,0,sizeof(level));
for(int i=0;i<n;i++)
{
scanf("%d%d",&x,&y);
x++;
level[sum(x)]++;
add(x);
}
for(int i=0;i<n;i++)
printf("%d\n",level[i]);
}
}


你可能感兴趣的:(POJ Stars)