Ignatius and the Princess III
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11780 Accepted Submission(s): 8340
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
Sample Output
题意:就是120以内的数进行整数拆分,问总共有多少拆分方法。
如 4可以有5种方式:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
总共有5种,所以输出5
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAX = 140;
int ans[MAX],tmp[MAX];
void work(int num){
int i,j,k;
memset(ans,0,sizeof(ans));
memset(tmp,0,sizeof(tmp));
for(i=0;i<=num;++i){
ans[i] = 1;
}
//(author : CSDN iaccepted)
for(i=2;i<=num;++i){
for(j=0;j<=num;++j){
for(k=0;k<=num && j+k*i<=num;++k){
tmp[j+k*i] += ans[j];
}
}
for(j=0;j<=num;++j){
ans[j] = tmp[j];
tmp[j] = 0;
}
}
}
int main(){
//freopen("in.txt","r",stdin);
//(author : CSDN iaccepted)
int num;
work(120);
while(scanf("%d",&num)!=EOF){
printf("%d\n",ans[num]);
}
return 0;
}