606第十周周六赛 H - 1sting 大数据处理


H - 1sting
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 1865

Description

You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get. 
 

Input

The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200. 
 

Output

The output contain n lines, each line output the number of result you can get . 
 

Sample Input

      
      
      
      
3 1 11 11111
 

Sample Output

      
      
      
      
1 2 8

大数据处理,真的并不擅长!

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
    int s[250][50]= {0};
    s[1][0]=1;
    s[2][0]=2;
    s[3][0]=3;
    for(int j=4; j<201; j++)
    {
        int jin=0;
        for(int i=0; i<50; i++)
        {
            s[j][i]=s[j-1][i]+s[j-2][i]+jin;
            jin=0;
            if(s[j][i]>9&&i<49)
            {
                jin=s[j][i]/10;
                s[j][i]=s[j][i]%10;
            }
        }
    }
    int t;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        char str[250];
        gets(str);
        int f=0;
        for(int i=49; i>=0; i--)
        {
            if(s[strlen(str)][i]==0&&f==0)
                continue;
            f=1;
            printf("%d",s[strlen(str)][i]);
        }
        printf("\n");
    }
    return 0;
}


你可能感兴趣的:(606第十周周六赛 H - 1sting 大数据处理)