HDU 1250 Hat's Fibonacci

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 
Input
Each line will contain an integers. Process to end of file.
 
Output
For each case, output the result in a line.
 
Sample Input
100
 
Sample Output
4203968145672990846840663646


Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
 

这个大家都懂,是个水题,知道用字符串作加法的这个肯定能懂,从左到右一位一位地加,题目中说答案不会超过2005个数字,而我一个int 存了8位,所以可以确定数组的第二维最多开个255就行,而1维嘛,10的2006次方大约等于2的7000多次方,所以开个8000足够;

LANGUAGE:C++

CODE:

#include<stdio.h>

int n,i,j,ans[8000][255]= {{0}};

int main()
{
    for(i=1; i<5; i++)ans[i][1]=1;
    for(i=5; i<8000; i++)
        for(j=1; j<255; j++)
        {
            ans[i][j]+=ans[i-1][j]+ans[i-2][j]+ans[i-3][j]+ans[i-4][j];
            ans[i][j+1]+=ans[i][j]/100000000;
            ans[i][j]=ans[i][j]%100000000;

        }

    while(scanf("%d",&n)!=EOF)
    {
        for(i=254; i>0; i--)
            if(ans[n][i])break;
        printf("%d",ans[n][i]);
        for(--i; i>0; i--)
            printf("%.8d",ans[n][i]);
        printf("\n");
    }
    return 0;
}


你可能感兴趣的:(input,each,output)