hdu3635(并查集)

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1686    Accepted Submission(s): 679


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.
hdu3635(并查集)_第1张图片
His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
   
   
   
   
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
   
   
   
   
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 

Author
possessor WC
 


本题是个并查集的实际应用。求该球所属的城市、该城市的总球数、该球的移动次数,这些可以对应并查集中求根节点、共同拥有该根节点的节点数、以及该节点到根节点的权值和。

int par[MAX];表示根节点
int sum[MAX];表示一该节点为根节点的节点数
int tran[MAX];表示该节点的权值,即移动次数

 

#include<iostream>
#include<cstdio>
using namespace std;

const int MAX=10000+10;
int par[MAX];
int sum[MAX];
int tran[MAX];


int Get_par(int a)
//查找a的父亲节点并压缩路径
{
	if(par[a]==a)
		return par[a];
	//注意语句的顺序
	int pa=par[a];
	par[a]=Get_par(par[a]);

	tran[a]+=tran[pa];////
	return par[a];
}


void Merge(int a,int b)
//合并a,b
{
	int pa,pb;
	pa=Get_par(a);
	pb=Get_par(b);

	tran[pa]=tran[pa]+1;///
	sum[pb]+=sum[pa];
	par[pa]=pb;
}

int main()
{
	int i,n,j,m,cas,tag=1;
	int a,b;
	char cmd[5];
	cin>>cas;
	while(cas--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			par[i]=i,sum[i]=1,tran[i]=0;

		printf("Case %d:\n",tag++);
		for(i=1;i<=m;i++)
		{
			scanf("%s",cmd);
			if(cmd[0]=='T')
			{
				scanf("%d%d",&a,&b);
				Merge(a,b);
			}
			else
			{
				scanf("%d",&a);
				int pa=Get_par(a);
				printf("%d %d %d\n",pa,sum[pa],tran[a]);

		/*		for(j=1;j<=n;j++)
				{
					printf("j=%d,  par[%d]=%d,  sum[%d]=%d,    tran[%d]=%d\n",j,j,par[j],j,sum[Get_par(j)],j,tran[j]);
				}*/
			}
		}

	}
	return 0;
}


 

你可能感兴趣的:(数据结构,并查集)