606第九周周六赛 C - Play a game双人游戏



C - Play a game
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  HDU 1564

Description

New Year is Coming! 
ailyanlu is very happy today! and he is playing a chessboard game with 8600. 
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can't make a move will lose the game. If both play perfectly, who will win the game?
 

Input

The input is a sequence of positive integers each in a separate line. 
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.
 

Output

Output the winner ("8600" or "ailyanlu") for each input line except the last zero. 
No other characters should be inserted in the output.
 

Sample Input

      
      
      
      
2 0
 

Sample Output

      
      
      
      
8600

一个寻找规律的题目,如果是偶数,先出手那个人赢,否则是另外一个人赢

1
2
3
4
5
6
7
8
9
10
11
12
13
#include<stdio.h>
int main()
{
    int a;
    while(scanf("%d",&a)&&a!=0)
    {
        if(a%2==0)
            printf("8600\n");
        else
            printf("ailyanlu\n");
    }
    return 0;
}

你可能感兴趣的:(606第九周周六赛 C - Play a game双人游戏)