hdoj 4349 Xiao Ming's Hope 【lucas 推广】



Xiao Ming's Hope

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1880    Accepted Submission(s): 1252


Problem Description
Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C (n,0)+C (n,1)+C (n,2)+...+C (n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C (1,0)=C (1,1)=1, there are 2 odd numbers. When n is equal to 2, C (2,0)=C (2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?
 

Input
Each line contains a integer n(1<=n<=10 8)
 

Output
A single line with the number of odd numbers of C (n,0),C (n,1),C (n,2)...C (n,n).
 

Sample Input
       
       
       
       
1 2 11
 

Sample Output
       
       
       
       
2 2 8
 



题意:问你C(n, 0)、C(n, 1)、 C(n, 2)、 C(n, 3)...C(n, n),里面有多少个是奇数。


lucas推广:

考虑C(n, m) % 2 

用a[0],a[1],a[2]...a[k]表示n的二进制,用b[0],b[1],b[2]...b[k]表示m的二进制。

那么C(n, m) == C(a[0], b[0]) * C(a[1], b[1])*...C(a[k], b[k]) (mod 2)。

我们知道C(0, 1) = 0, C(1, 0) = C(1, 1) = 1。

为了保证结果 % 2 != 0,我们必须保证(a[i] = 0,b[i] = 1)的情况不能出现,相反的a[i] = 1,b[i]可以任意。


这样结果就出来了,求出n的二进制中1的个数cnt,答案就是2 ^ cnt。


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
    int n;
    while(scanf("%d", &n) != EOF)
    {
        int cnt = 0;
        while(n)
        {
            if(n & 1)
                cnt++;
            n >>= 1;
        }
        printf("%d\n", (1<<cnt));
    }
    return 0;
}



你可能感兴趣的:(hdoj 4349 Xiao Ming's Hope 【lucas 推广】)