1452 - Jump(dp+约瑟夫环变形)

Integers 1, 2, 3,..., n are placed on a circle in the increasing order as in the following figure. We want to construct a sequence from these numbers on a circle. Starting with the number 1, we continually go round by picking out each k-th number and send to a sequence queue until all numbers on the circle are exhausted. This linearly arranged numbers in the queue are called Jump(nk) sequence where 1nk.

Let us compute Jump(10, 2) sequence. The first 5 picked numbers are 2, 4, 6, 8, 10 as shown in the following figure. And 3, 7, 1, 9 and 5 will follow. So we get Jump(10, 2) = [2,4,6,8,10,3,7,1,9,5]. In a similar way, we can get easily Jump(13, 3) = [3,6,9,12,2,7,11,4,10,5,1,8,13], Jump(13, 10) = [10,7,5,4,6,9,13,8,3,12,1,11,2] and Jump(10, 19) = [9,10,3,8,1,6,4,5,7,2].

Jump(10,2) = [2,4,6,8,10,3,7,1,9,5]

You write a program to print out the last three numbers of Jump(nk) for nk given. For example suppose that n = 10k = 2, then you should print 1, 9 and 5 on the output file. Note that Jump(1, k) = [1].

Input 

Your program is to read the input from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing two integers n and k, where 5n500, 000 and 2k500, 000.

Output 

Your program is to write to standard output. Print the last three numbers of Jump(nk) in the order of the last third, second and the last first. The following shows sample input and output for three test cases.

Sample Input 

3 
10 2 
13 10 
30000 54321

Sample Output 

1 9 5 
1 11 2 
10775 17638 23432

题意:给定一个1-n的数字环,每次跳k步,求最后3个数。

思路:约瑟夫环的变形,最后1个数的求法就是基本的约瑟夫环,对于2,3个数而言,就当做是在i==2和i==3的时候,和其他编号不一样的就是他们当前的编号,那么就从这个位置推到n即可。

代码:

#include <stdio.h>
#include <string.h>

int t, n, k;

int main() {
	scanf("%d", &t);
	while (t--) {
		scanf("%d%d", &n, &k);
		int ans1 = 0, ans2 = 0, ans3 = 0;
		for (int i = 2; i <= n; i++) {
			ans1 = (ans1 + k) % i;
			if (i == 2) ans2 = 1 - ans1;
			else {
				ans2 = (ans2 + k) % i;
				if (i == 3) ans3 = 3 - ans2 - ans1;
				else ans3 = (ans3 + k) % i;
			}
		}
		printf("%d %d %d\n", ans3 + 1, ans2 + 1, ans1 + 1);
	}
	return 0;
}


你可能感兴趣的:(1452 - Jump(dp+约瑟夫环变形))