Find them, Catch them
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 14572 |
|
Accepted: 4239 |
Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)
Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:
1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.
2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output
For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input
1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4
Sample Output
Not sure yet.
In different gangs.
In the same gang.
Source
POJ Monthly--2004.07.18
#include<cstdio>
#include<cstring>
int n,m;
struct TT
{
int f,o;
} p[100010];
int find(int a)
{
if(a!=p[a].f) p[a].f=find(p[a].f);
return p[a].f;
}
void Union(int a,int b)
{
a=find(a);
b=find(b);
p[a].f=b;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)
{
p[i].f=i;
p[i].o=i;
}
for(int i=1; i<=m; i++)
{
char str[10];
int a,b;
scanf("%s%d%d",str,&a,&b);
if(str[0]=='A')
{
int fa=find(a),fb=find(b);
if(fa==fb)
printf("In the same gang./n");
else if(fa==find(p[fb].o))
printf("In different gangs./n");
else
printf("Not sure yet./n");
/*if(!vis[a]||!vis[b]) printf("Not sure yet./n");
else
{
a=find(a);
b=find(b);
if(a==b) printf("In the same gang./n");
else printf("In different gangs./n");
}
这么判断是错误的,因为比如1,2已经被访问,属于不同集合
再访问3,4属于不同的集合,照我原来的思路,那么就应该输出属于不同
的集合,其实应该是不确定。判断逻辑错了
*/
}
else
{
if(p[a].o==a) p[a].o=b;
else Union(p[a].o,b);
if(p[b].o==b) p[b].o=a;
else Union(p[b].o,a);
}
}
}
return 0;
}