1554 - Binary Search(暴力枚举)

The program fragment below performs binary search of an integer number in an array that is sorted in a nondescending order:

Pascal (file "sproc.pas") C (file "sproc.c")
const
  MAXN = 10000;
var
  A: array[0..MAXN-1] of integer;
  N: integer;

procedure BinarySearch(x: integer);
var
  p, q, i, L: integer;
begin
  p := 0;   { Left border of the search  }
  q := N-1; { Right border of the search }
  L := 0;   { Comparison counter         }
  while p <= q do begin
    i := (p + q) div 2;
    inc(L);
    if A[i] = x then begin
      writeln('Found item i = ', i,
        ' in L = ', L, ' comparisons');
      exit
    end;
    if x < A[i] then
      q := i - 1
    else
      p := i + 1
  end
end;

#define MAXN 10000

int A[MAXN];
int N;

void BinarySearch(int x)
{
  int p, q, i, L;

  p = 0;   /* Left border of the search  */
  q = N-1; /* Right border of the search */
  L = 0;   /* Comparison counter         */
  while (p <= q) {
    i = (p + q) / 2;
    ++L;
    if (A[i] == x) {
      printf("Found item i = %d"
        " in L = %d comparisons\n", i, L);
      return;
    }
    if (x < A[i])
      q = i - 1;
    else
      p = i + 1;
  }
}

Before BinarySearch was called, N was set to some integer number from 1 to 10000 inclusive and array A was filled with a nondescending integer sequence.

It is known that the procedure has terminated with the message "Found item i = XXX in L = XXX comparisons" with some known values of i and L.

Your task is to write a program that finds all possible values of N that could lead to such message. However, the number of possible values of N can be quite big. Thus, you are asked to group all consecutiveNs into intervals and write down only first and last value in each interval.

Input 

The input file consists of several datasets. Each datasets consists of a single line with two integers i andL (0 ≤ i < 10000 and 1 ≤ L ≤ 14), separated by a space.

Output 

On the first line of each dataset write the single integer number K representing the total number of intervals for possible values of N. Then K lines shall follow listing those intervals in an ascending order. Each line shall contain two integers Ai and Bi (Ai ≤ Bi) separated by a space, representing first and last value of the interval.

If there are no possible values of N exist, then the output file shall contain the single 0.

Sample Input 

10 3

Sample Output 

4
12 12
17 18
29 30
87 94

题意:给定n和L,要求在1-10000内的数找出能在L次二分出n的数字,输出这些数字的各个区间。

思路:暴力1-10000去判断即可。二分按照题目那个代码就可以了。

代码:

#include <stdio.h>
#include <string.h>

const int N = 10005;
int n, L, i, vis[N], ans[N], ansn;

bool judge(int x) {
	int l = 0, r = x - 1, cnt = 0;
	while (l <= r) {
		int mid = (l + r) / 2;
		cnt++;
		if (cnt > L) return false;
		if (mid == n && cnt == L) return true;
		if (mid < n) l = mid + 1;
		else r = mid - 1;
	}
	return false;
}

int main() {
	while (~scanf("%d%d", &n, &L)) {
		ansn = 0;
		memset(vis, 0, sizeof(vis));
		for (i = n + 1; i <= 10000; i++) {
			if (judge(i))
				vis[i] = 1;
			if (vis[i] == 1 && vis[i - 1] == 0)
				ans[ansn++] = i;
			else if (vis[i] == 0 && vis[i - 1] == 1)
				ans[ansn++] = i - 1;
		}
		if (vis[10000] == 1)
			ans[ansn++] =  10000;
		printf("%d\n", ansn / 2);
		for (i = 0; i < ansn; i++) {
			printf("%d", ans[i]);
			if (i % 2) printf("\n");
			else printf(" ");
		}
	}
	return 0;
}


你可能感兴趣的:(1554 - Binary Search(暴力枚举))