蓝桥杯第二次选拔D.Leftmost Digit

/*D.Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13082    Accepted Submission(s): 5009


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
2
3
4
 

Sample Output
2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


 题目大意 :求解n的n次方的最左边的数

题目分析 :  因为数字太大,考虑用对数  
           主要思路是任意数num可以表示为:num ^ num = a * 10 ^ n(a的整数部分即为所求解, n为位数)
           两边取对数:num * lg(num) = lg(a) + n,  令x = num * lg(num)  
           则n为x的整数部分,lg(a)为x的小数部分,所以lg(a) = x - n
           a = 10 ^ (x - n) => a = 10 ^ (x - (long long)x) 这里注意转换的的时候不能用int, 因为double表示的范围远大于int
*/


#include <cmath>  
#include <cstdio>  
int main()  
{  
    int T;  
    scanf("%d",&T);  
    while(T--)  
    {     
        int num;  
        scanf("%d",&num);  
        double x = num * log10(num);  
        printf("%d\n", (int) pow(10.0 , (x - (long long)x)));  
    }  
    return 0;  
} 
 //代码如此简洁,当时最终8wa也没做出来。 
//虽然说是数学的推导,但是始终都是计算机的思想在里面,比如整数部分和小数部分直接改成整型就可以分离出整数部分。
//还有大数 次方爆了所有类型,所以就用计算机中的log对数运算,不会爆浮点型,但是小数部分误差大,但是整数部分不可能有误差,又体现了计算机的思想。 

你可能感兴趣的:(蓝桥杯第二次选拔D.Leftmost Digit)