UVa 10783 Odd Sum (water ver.)

10783 - Odd Sum

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=19&page=show_problem&problem=1724

Given a range [ab], you are to find the summation of all the odd integers in this range. For example, the summation of all the odd integers in the range [3, 9] is 3 + 5 + 7 + 9 = 24.

Input 

There can be at multiple test cases. The first line of input gives you the number of test cases,  T  (   1T100 ). Then T test cases follow. Each test case consists of 2 integers  a  and  b  (   0ab100 ) in two separate lines.

Output 

For each test case you are to print one line of output - the serial number of the test case followed by the summation of the odd integers in the range  [ab] .

Sample Input 

2
1
5
3
5

Sample Output 

Case 1: 9
Case 2: 8

完整代码:

/*0.006s*/

#include <cstdio>

int main(void)
{
	int t, a, b;
	scanf("%d", &t);
	for (int i = 1; i <= t; ++i)
	{
		scanf("%d%d", &a, &b);
		a >>= 1, b = (b + 1) >> 1;
		printf("Case %d: %d\n", i, b * b - a * a);
	}
	return 0;
}

你可能感兴趣的:(C++,ACM,uva)