Hduoj2178【文字题】

/*猜数字 
Time Limit : 3000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia 
Font Size: ← →
Problem Description
A有1数m,B来猜.B每猜一次,A就说"太大","太小"或"对了" 。 
问B猜n次可以猜到的最大数。 

Input
第1行是整数T,表示有T组数据,下面有T行 
每行一个整数n (1 ≤ n ≤ 30) 

Output
猜n次可以猜到的最大数

Sample Input
2
1
3
Sample Output
1
7

Author
Zhousc 
Source
ECJTU 2008 Summer Contest */
//题意:猜测n次必然能猜出答案,求m的值,即1~m的范围 
#include<stdio.h>
int main()
{
	int T, i, n;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%d", &n);
		i = 2;
		while(--n)
		{
			i *= 2;
		}
		printf("%d\n", i-1);
	}
	return 0;
}

你可能感兴趣的:(Hduoj2178【文字题】)