POJ 3401 Asteroids 二分图最大匹配

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 18208   Accepted: 9917

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X. 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold
把x,y分别作为点如果有小行星就看作一条边,那么要求的就是最小覆盖点,根据kOning定理:
最小覆盖点=最大匹配数
套匈牙利模板
ACcode:
#pragma warning(disable:4786)//使命名长度不受限制
#pragma comment(linker, "/STACK:102400000,102400000")//手工开栈
#include <map>
#include <set>
#include <queue>
#include <cmath>
#include <stack>
#include <cctype>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define rd(x) scanf("%d",&x)
#define rd2(x,y) scanf("%d%d",&x,&y)
#define rds(x) scanf("%s",x)
#define rdc(x) scanf("%c",&x)
#define ll long long int
#define maxn 505
#define mod 1000000007
#define INF 0x3f3f3f3f //int 最大值
#define FOR(i,f_start,f_end) for(int i=f_start;i<=f_end;++i)
#define MT(x,i) memset(x,i,sizeof(x))
#define PI  acos(-1.0)
#define E  exp(1)
using namespace std;
bool bmap[maxn][maxn];
bool bmask[maxn];
int n,m,x,y;
int cx[maxn];
int findpath(int u){
    FOR(i,1,n)
        if(bmap[u][i]&&!bmask[i]){
            bmask[i]=1;
            if(cx[i]==-1||findpath(cx[i])){
                cx[i]=u;
                return 1;
            }
        }
    return 0;
}
int MaxMatch(){
    int res(0);
    FOR(i,1,n){
        MT(bmask,false);
        if(findpath(i))
            res++;
    }
    return res;
}
int main(){
    while(rd2(n,m)!=EOF){
        MT(bmap,0);
        MT(bmask,0);
        MT(cx,-1);
        FOR(i,1,m){
            rd2(x,y);
            bmap[x][y]=1;
        }
        printf("%d\n",MaxMatch());
    }
    return 0;
}
/*
3 4
1 1
1 3
2 2
3 2
*/


你可能感兴趣的:(C++,poj,二分图)