zoj3822 Domination 牡丹江现场赛D题 概率DP

Domination Time Limit: 8 Seconds      Memory Limit: 131072 KB      Special Judge

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What's more, he bought a large decorative chessboard withN rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard wasdominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

"That's interesting!" Edward said. He wants to know the expectation number of days to make an empty chessboard ofN × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2

Sample Output

3.000000000000
2.666666666667

  N*M的格子,每次在空格上随机放一个棋子,问放的次数的期望,使每行每列至少有一个棋子。

  dp[i][j][k]表示已经有i行j列有棋子,并且已经放了k个棋子的概率。那么转移方程就好写了。注意当i==N并且j==M的时候没有dp[i][j][k]不能加上dp[i][j][k-1]*(i*j-k+1)/(N*M-k+1),因为如果到达dp[N][M][K-1],游戏结束,不可能由这个到达dp[N][M][K]。

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<algorithm>
#define eps 1e-9
#define MAXN 55
#define MAXM 55
#define MAXNODE MAXN*4
#define MOD 999983
typedef long long LL;
using namespace std;
int T,N,M;
double dp[MAXN][MAXN][MAXN*MAXN];
void DP(){
    memset(dp,0,sizeof(dp));
    dp[0][0][0]=1;
    for(int i=1;i<=N;i++)
        for(int j=1;j<=M;j++)
            for(int k=1;k<=M*N;k++){
                if(i==N&&j==M) dp[i][j][k]=dp[i-1][j][k-1]*((N-i+1)*j)/(N*M-k+1)+
                                           dp[i][j-1][k-1]*(i*(M-j+1))/(N*M-k+1)+
                                           dp[i-1][j-1][k-1]*(N-i+1)*(M-j+1)/(N*M-k+1);
                else dp[i][j][k]=dp[i-1][j][k-1]*((N-i+1)*j)/(N*M-k+1)+
                                 dp[i][j-1][k-1]*(i*(M-j+1))/(N*M-k+1)+
                                 dp[i-1][j-1][k-1]*(N-i+1)*(M-j+1)/(N*M-k+1)+
                                 dp[i][j][k-1]*(i*j-k+1)/(N*M-k+1);
            }
}
int main(){
    freopen("in.txt","r",stdin);
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&N,&M);
        DP();
        double ans=0;
        for(int i=0;i<=M*N;i++) ans+=dp[N][M][i]*i;
        printf("%.12lf\n",ans);
    }
    return 0;
}



你可能感兴趣的:(zoj3822 Domination 牡丹江现场赛D题 概率DP)