NYOJ27 水池数目 【深搜】+【广搜】

水池数目

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述
南阳理工学院校园里有一些小河和一些湖泊,现在,我们把它们通一看成水池,假设有一张我们学校的某处的地图,这个地图上仅标识了此处是否是水池,现在,你的任务来了,请用计算机算出该地图中共有几个水池。
输入
第一行输入一个整数N,表示共有N组测试数据
每一组数据都是先输入该地图的行数m(0<m<100)与列数n(0<n<100),然后,输入接下来的m行每行输入n个数,表示此处有水还是没水(1表示此处是水池,0表示此处是地面)
输出
输出该地图中水池的个数。
要注意,每个水池的旁边(上下左右四个位置)如果还是水池的话的话,它们可以看做是同一个水池。
样例输入
2
3 4
1 0 0 0 
0 0 1 1
1 1 1 0
5 5
1 1 1 1 0
0 0 1 0 1
0 0 0 0 0
1 1 1 0 0
0 0 1 1 1
样例输出
2
3

深搜:

#include <stdio.h>
#define max 102

int m, n;
bool arr[max][max];

void DFS(int i, int j){
	arr[i][j] = 0;
	if(arr[i-1][j]) DFS(i - 1, j); //向上
	if(arr[i][j-1]) DFS(i, j - 1); //向左
	if(arr[i + 1][j]) DFS(i + 1, j); //向下
	if(arr[i][j + 1]) DFS(i, j + 1); //向右
}

int main(){
	int t, temp, count;
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &m, &n);
		for(int i = 1; i <= m; ++i)
			for(int j = 1; j <= n; ++j)
				scanf("%d", &temp), arr[i][j] = temp;
				
		count = 0;
		
		for(int i = 1; i <= m; ++i)
			for(int j = 1; j <= n; ++j){
				if(arr[i][j]){
					++count;
					DFS(i, j);
				}
			}
			
		printf("%d\n", count);
	}
	return 0;
}

广搜:

#include <stdio.h>
#include <queue>
#define max 102
using namespace std;

struct Node{
	int x, y;
}temp, tem;
int m, n, arr[max][max];
queue<Node> que;

void BFS(){	
	while(!que.empty()){
		tem = temp = que.front();
		arr[temp.x][temp.y] = 0;
				
		if(arr[tem.x-1][tem.y]){
			--temp.x;
			que.push(temp);
		}
		
		if(arr[tem.x+1][tem.y]){
			temp = tem;
			++temp.x;
			que.push(temp);
		}
		
		if(arr[tem.x][tem.y-1]){
			temp = tem;
			--temp.y;
			que.push(temp);
		}
		
		if(arr[tem.x][tem.y+1]){
			temp = tem;
			++temp.y;
			que.push(temp);
		}
		que.pop();
	}
	
}

int main(){
	int t, count;
	
	scanf("%d", &t);
	while(t--){
		scanf("%d%d", &m, &n);
		
		for(int i = 1; i <= m; ++i)
			for(int j = 1; j <= n; ++j) scanf("%d", &arr[i][j]);
		
		count = 0;
		for(int i = 1; i <= m; ++i)
			for(int j = 1; j <= n; ++j){
				if(arr[i][j]){
					temp.x = i, temp.y = j, que.push(temp);
					++count;
					BFS();
				}
			}
			
		printf("%d\n", count);
	}
	return 0;
}

深搜效率更高。

你可能感兴趣的:(NYOJ27)