POJ 2084 Game of Connections(卡特兰数,JAVA)

A - Game of Connections
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

This is a small but ancient game. You are supposed to write down the numbers 1, 2, 3, . . . , 2n - 1, 2n consecutively in clockwise order on the ground to form a circle, and then, to draw some straight line segments to connect them into number pairs. Every number must be connected to exactly one another. 
And, no two segments are allowed to intersect. 
It's still a simple game, isn't it? But after you've written down the 2n numbers, can you tell me in how many different ways can you connect the numbers into pairs? Life is harder, right?

Input

Each line of the input file will be a single positive number n, except the last line, which is a number -1. 
You may assume that 1 <= n <= 100.

Output

For each n, print in a single line the number of ways to connect the 2n numbers into pairs.

Sample Input

2
3
-1

Sample Output

2
5
分析:卡特兰数,大数处理


import java.io.*;
import java.math.*;
import java.util.*;
import java.text.*;
 
public class Main {
    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        BigInteger t1, t2, dp[] = new BigInteger[105];
        dp[1] = BigInteger.valueOf(1);
        for(int i = 2; i <= 100; i ++){
            t1 = BigInteger.valueOf(4 * i - 2); //  要注意(4n-2)/(n+1)可能为小数。
            t2 = BigInteger.valueOf(i + 1);
            dp[i] = dp[i-1].multiply(t1).divide(t2);
        }
        while(cin.hasNext()){
            int id = cin.nextInt();
            if(id == -1) break;
            System.out.println(dp[id]);
        }
        System.exit(0);
    }
}


你可能感兴趣的:(POJ 2084 Game of Connections(卡特兰数,JAVA))