Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8665 Accepted Submission(s): 3541
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
//先排个序,然后从第一个未访问的开始依次访问所有len,wei都大于或等于它的结点,重复进行直到结束,重复次数即为所求!
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node
{
int len,wei;
bool flag;
}da[5000+10];
bool cmp(node a,node b)
{
if(a.len!=b.len)
return a.len<b.len;
else
return a.wei<b.wei;
}
int main()
{
int i,t,n,k,st,ans;
cin>>t;
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d%d",&da[i].len,&da[i].wei);
da[i].flag=false;
}
sort(da,da+n,cmp);
ans=0;
k=0;
while(k<=n-1)
{
for(i=0;i<n;i++)
{
if(!da[i].flag)
{
da[i].flag=true;
k++;
ans++;
st=i;
break;
}
}
for(i=st+1;i<n;i++)
{
if(!da[i].flag&&da[i].len>=da[st].len&&da[i].wei>=da[st].wei)
{
da[i].flag=true;
k++;
st=i;
}
}
}
printf("%d\n",ans);
}
return 0;
}