PAT (Advanced Level) Practise 1002 A+B for Polynomials (25)

1002. A+B for Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
就是按位相加,注意把0的位去掉
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<iostream>
#include<stack>
#include<algorithm>
#include<bitset>
#include<functional>
#include<ctime>
using namespace std;
typedef unsigned long long ull;
typedef long long LL;
const int maxn = 1e3 + 10;
const int INF = 0x7FFFFFFF;
float f[maxn], y;
int n, x, cnt = 0;

int main()
{
  for (int i = 0; i < 2; i++)
  {
    scanf("%d", &n);
    while (n--)
    {
      scanf("%d%f", &x, &y);
      f[x] += y;
    }
  }
  for (int i = 0; i < maxn; i++) if (f[i] != 0) cnt++;
  printf("%d", cnt);
  for (int i = maxn - 1; i >= 0; i--) if (f[i] != 0) printf(" %d %.1f", i, f[i]);
  printf("\n");
  return 0;
}


你可能感兴趣的:(pat)