HDOJ题目地址:传送门
Climbing Worm
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16407 Accepted Submission(s): 11180
Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
Sample Output
题意:一只虫子从井中往上爬,每分钟爬 u ,休息一分钟,一分钟休息的时候下滑 d ,求最后爬上井的时间。
这是一道巨简单的水题。
#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
//n表示井的深度,u表示虫子每分钟爬多高,d表示虫子每分钟掉多少
int n,u,d,result;
while(scanf("%d%d%d",&n,&u,&d)&&n&&u&&d){
result=0;
while(1){
n-=u;
result++;
if(n<=0)break;
n+=d;
result++;
}
printf("%d\n",result);
}
}