HDU5365Run(计算几何)详解

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=5365

题目:

Run

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 853    Accepted Submission(s): 370


Problem Description
AFA is a girl who like runing.Today,he download an app about runing .The app can record the trace of her runing.AFA will start runing in the park.There are many chairs in the park,and AFA will start his runing in a chair and end in this chair.Between two chairs,she running in a line.she want the the trace can be a regular triangle or a square or a regular pentagon or a regular hexagon.
Please tell her how many ways can her find.
Two ways are same if the set of chair that they contains are same.
 

Input
There are multiply case.
In each case,there is a integer n(1 < = n < = 20)in a line.
In next n lines,there are two integers xi,yi(0 < = xi,yi < 9) in each line.
 

Output
Output the number of ways.
 

Sample Input
   
   
   
   
4 0 0 0 1 1 0 1 1
 

Sample Output
   
   
   
   
1
题意:

给你几个整数点,找出这几个点所组成的正N边型,因为所有的点都是整数的,所以只需要判断是否为正四边形。

思路

我的做法是判断组成图形的4条边相互垂直且相等

#include<stdio.h>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <string>
using namespace std;

typedef long long ll;

int n;
struct Point
{
    int x,y;
}p[25];

int dis2(Point a,Point b)//用来判断两点距离
{
    return (a.x -b.x)*(a.x - b.x) + (a.y - b.y)*(a.y-b.y);
}
int chaji(Point a,Point b,Point c)//求两条直线的叉积
{
    return (a.x-b.x)*(c.x-b.x) + (a.y-b.y)*(c.y-b.y);
}

bool ok(Point a,Point b,Point c)//判断两条边是否垂直且相等
{
    if(chaji(a,b,c) == 0 && dis2(a,b) == dis2(b,c))
        return true;
    return false;
}
int main()
{

    while(scanf("%d",&n) != EOF)
    {
        int a,b;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&p[i].x,&p[i].y);
        }
        ll ans = 0;
        for(int i=0;i<n;i++)
        {

            for(int j=0;j<n;j++)
            {
                if(j == i) continue;
                for(int k=0;k<n;k++)
                {
                    if(k == i || k == j) continue;
                    for(int q=0;q<n;q++)
                    {
                        if(q == i ||q == j || q == k) continue;
                        Point a = p[i];
                        Point b = p[j];
                        Point c = p[k];
                        Point d = p[q];
                        if(ok(a,b,c) && ok(b,c,d) && ok(c,d,a) && ok(d,a,b))
                        {
                            ans ++;
                        }
                    }
                }
            }
        }

        printf("%I64d\n",ans/8 );//因为平时是4,正逆两个方向,所以除以8
    }
    //while(1);

}




你可能感兴趣的:(HDU5365Run(计算几何)详解)